How to archive CodeTwo Public Folders data

Problem:

You need to back up or archive public folders synchronized by CodeTwo Public Folders.

Solution:

There are three methods of archiving data synchronized by CodeTwo Public Folders:

CodeTwo Public Folders files are located in the C2PublicFolders folder. Archiving parts of the data kept in this folder may be useful, especially when the PST file (where the local copy of public folder data is stored) is too large.

Important

The methods described in this article allow you to back up only the public folders that you can access. If you see certain folders or items in the C2PublicFolders tree, but you do not have permissions to view them, these elements will not be backed up.

Using the archiving tool in Outlook

To archive items from the C2PublicFolders tree depending on their modification date, follow these steps: 

  1. Run the archiving tool in Outlook on one of the (client) computers with Outlook Add-in installed (this computer should have access to all public folders). The location of this tool depends on your Outlook version:
    • In Outlook 2016: Click the File menu and go to Info > Tools > Clean Up Old Items. A new window opens (Fig. 1.).
       

      103-1
      Fig. 1. The archiving tool in Outlook 2016 (the window looks similar in all Outlook versions).

    • In Outlook 2013: Click the File menu and go to Info > Cleanup Tools > Archive.
    • In Outlook 2010: Click the File tab, click Cleanup Tools and then click Archive.
    • In Outlook 2007: On the File menu, click Archive.
  2. Select Archive this folder and all subfolders and configure the rest of the available options (see Fig. 1.) according to your preferences.
  3. Once the archiving is finished, copy the PST file containing the archive and upload it onto the remaining users' local disks.
  4. If these users want to view the archived items, they need to:
    • open their Outlook and click File Open (or Open & Export) > Outlook Data File;
    • find the archived PST file and click OK. A new tree containing the archive will be created in their folder list in Outlook.

Manual archiving in a new Outlook Data File (PST)

Another archiving method is creating a new Outlook Data File (in the PST format) and manually selecting the elements to be archived. Here is how to do it:

  1. Create a new PST file on one of the computers with Outlook Add-in installed:
    • If you use Outlook 2016, 2013 and 2010: in your Inbox, click New Items > More Items > Outlook Data File (Fig. 2.).
       

      103-2
      Fig. 2. How to create a new Outlook Data File in Outlook 2016.

    • If you use Outlook 2007: click File > New > Outlook Data File. Choose Office Outlook Personal Folders File (.pst)
  2. Choose or create a folder that will be responsible for storing the archive and provide the name for the data file.
  3. A new tree will be created in Outlook. Move items from C2PublicFolders to the newly created tree in the folder list by using drag & drop or keyboard shortcuts (Crtl+X and Ctrl+V). 
  4. Once the manual archiving is finished, the newly created PST file should be copied and opened on the remaining computers that have Outlook Add-in installed (see steps 3-4 in section Using the archiving tool in Outlook).

Archiving data on the Syncing Master (server module)

It is also possible to archive data on the Syncing Master. It can be done when a PST file has almost reached its size limit (for example, the size limit in Outlook 2003 and Outlook 2007 is 20 GB; older versions of Outlook cannot exceed 2 GB) and working with public folders is no longer possible. You need to do the following:

  1. Stop the C2PublicFolders service:
    • In Windows 10: click the Start menu, type services.msc and press Enter. Locate C2PublicFolders on the list of all services, right-click it and choose Stop.
    • In older Windows versions: Open Control Panel and go to Administrative Tools Services. Locate C2PublicFolders on the list of all services, right-click it and choose Stop.
  2. Open the main installation folder of the Syncing Master and locate the Data folder. Move the files that are selected for archiving to another folder (each of these files corresponds to one element in the public folders).
  3. Restart the C2PublicFolders service.
  4. If these archives are to be visible for other users, a new PST file needs to be created in Outlook (as described in section Manual archiving in a new Outlook Data File (PST)) and the archived files need to be moved to this tree (see steps 3-4 in section Using the archiving tool in Outlook).

Warning

Please bear in mind that the archived items will no longer sync between the Outlook Add-ins. If one user makes any changes to the items residing in the archive tree, the changes will not synchronize with other users. Therefore, it is recommended to archive only the items that will not require any modifications in the future.